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Securely keeps all your confidential info. 
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Overview 
 

Secret Keeper is a versatile database application that securely keeps all your confidential 
info in one place. It lets you store and manage all your passwords, user ID, email accounts, 
web accounts/memberships, credit cards, bank cards, lock numbers, home inventory, movie 
collections, contact lists, and just about anything you want to keep secret & secure. 
 
The program encrypts and saves all records in a database. So, the only thing you need to 
remember is just the master password for the program 
 
System Requirements: 
 Microsoft Windows 98, Windows 2000, Windows NT, Windows XP. 
 An  Intel Pentium 3 class of computer or better. 

 
 
Getting Started 

 
This section is intended to give you a quick orientation of the program. It will briefly touch 
on a few of the main functionalities.  
 

 

 
The Login screen. 

 
1. Launch Secret Keeper 2 (SK2) from Program Files\Hilary Technology\SecretKeeper 2 
2. For initial login, enter 123 as the password. 
3. Click Ok to login to see the main screen. 
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Main menu
Tool bar

Category list 
which 
displays all 
categories. 

Record list which 
displays all 
records belonging 
to the selected 
category. 

The Main screen. 
 

New Record 

Generate Password

Print Preview

User Guide

Clear Filterbar

Clear Clipboard 

Lock Program The Toolbar

Show/Hide Filterbar

New Category 

 
 
4. At this point, you can double click on a category to see the category management 

screen. Or double click on a record to see the record management screen. 
5. Right click your mouse over the Category list or Record list to bring up the shortcut 

menus available. 
6. The same sets of shortcut menu items are also available under the Category and 

Record sections in the main menu. 
7. Basically, the program is about managing and saving categories and records securely. 

That’s it. You are now ready to explore other features in the main menu and toolbar. 
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Changing Master Password 
 
It’s recommended that you change the master password from the default one.  
 

 
The Change Master Password screen. 
 
1. Launch the Change Master Password screen from Tools>Change Master Password in 

the main menu. 
2. Enter the new password twice. 
3. Click on Save. 
 
Note: 
 It’s recommended that you use longer password (>= 8 characters). And that you use 

combination of letters and numbers for optimal protection. 
 It’s absolutely important that you remember your master password because even us at 

Hilary Technology can not break or unlock the program for you if you lose or forget it. 
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Managing Categories 
 

With the Category Management screen, you can create your own categories and the 
associated fields. 

 

 

The category 
name. 
 Field list 

containing user-
defined fields 
associated with 
the specified 
category. 

Buttons to arrange 
field ordering 
and to delete 
fields. 

 
  

Note 
 Field Name has maximum length of 50 characters. 
 Shortcut menu items are available when right clicking on the mouse over the Category 

list in the main screen. 
 Field ordering and field deletion can only be done during editing mode, not Add-New-

field mode.  
  

 
Adding a category 
1. From the main menu, go to File>New Category OR click the Blue Arrow button on 

the tool bar to launch the Category Management screen. 
2. Type in the desired category name 
3. Type in the desired field names in the field list. 
4. If you want a particular field to show up as “******”, select the Masked checkbox, so 

that the field values are masked when being displayed.  
You can either show or hide the masked fields in the main screen using the Show 
Masked Fields option under the View section in the main menu.  

5. If you have an URL type field, select the URL checkbox, so that such field values will 
be displayed with a button right beside them for launching the web browser.  

6. Click OK to finish or Click Cancel to exit without saving. 

Copyright 2009, Hilary Technology Inc. All rights reserved.                         Page 5 of 14 



Updating a category 
1. From the main menu, go to Edit>Edit Category OR double-click the Category from the 

Category list on the main screen.  
2. You can change the Category name and/or field names. 
3. You can use the UP & Down arrow buttons to re-arrange the order of the fields.  
4. You may delete fields using the Red Delete(X) button. 
5. Click OK to save or Click Cancel to exit without saving.  
 
Duplicating a category 
1. Highlight the desired category from the Category list on the main screen. 
2. From the main menu, go to Edit > Duplicate Category OR Right Click to use the 

shortcut menu.  The category will then be duplicated along with the associated fields. 
The records however will not be duplicated. 

 
Deleting a category 
1. Highlight the desired category from the Category list on the main screen. 
2. From the main menu, go to Edit > Delete Category OR Right Click to use the shortcut 

menu. You will be asked whether you want to continue with the deletion. 
3. Click OK to delete. Click Cancel to exit without deleting.  
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Managing Records 
 

With the Record Management screen, you can add and update records for a specified 
category. 

 

 
The Record Management screen. 

 
Note 
 Field Value has maximum length of 200 characters. 
 Shortcut menu items are available when right clicking on the mouse over the Record 

list in the main screen. 
 

Adding a Record 
1. Select the desired category from the Category list on the main screen first.  
2. On the main menu, go to File>New Record OR click the Green Arrow button on the 

toolbar. 
3. Enter information into the record. 
4. Click OK to save. Click Cancel to exit without saving. 
5. If you want to have passwords automatically generated for you, click Generate Pwd 

button to launch the tool. You can copy and paste the auto-generated password in the 
value field of a record (see Generating Passwords section for details). 

 
Updating a Record 
1. Select the desired record from the record list.  
2. On the main menu, go to Edit>Edit Record OR double click the record. 
3. Update the field values as needed in the record. 
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4. Click OK to save. Click Cancel to exit without saving. 
5. If you need to generate a password, click Generate Pwd button (see Generating 

Passwords section for details). 
 

Deleting a Record 
1. Select the desired record from the record list.  
2. On the main menu, go to Edit>Delete Record, or Right Click to use the shortcut menu. 
3. You will be asked whether you want to continue with the deletion. 
4. Click OK to delete. Click Cancel to exit without deleting.  
 
 

Generating Passwords 
 

The Password Generation screen can automatically generate passwords for you to be used 
as user passwords, account passwords or just any passwords that you want to use with SK2 
or outside of SK2. 

 

 

Select what case 
you want your 
letters to appear 
in. 

Select what type 
of characters you 
want. 

Password will be 
displayed after 
clicking on the 
Generate button. 

 
1. Select whether you want the letters in your password to be upper or lower case. 
2. Select the type of characters you want – letters, numbers, or a mix of both.  
3. Type in the length that you want the password to be.  
4. Click Generate to create the password.  
5. Click Copy to copy the password so that you can paste the password later on in a 

record.  
6. Click Close to exit.  

 
 
Printing Records 
 

Previewing / Printing Records 
You can preview and print out the records for a particular category. 
 

Copyright 2009, Hilary Technology Inc. All rights reserved.                         Page 8 of 14 



Note: 
 Content in the print preview will be identical to that of Record list in the main window, 

so please adjust the Record list in the main window to your satisfaction before printing 
the records out. 

 
1. Highlight the Category from the Category list on the main screen. 
2. On the main menu, go to File>Print Preview Or Click on Print Preview on the toolbar. 
3. Set Page Setup options as needed in the Preview window. 
4. Print or Cancel as needed. 

 
 
Exporting Records 

 
You can export records of selected categories in Excel format.   
 

 
 
Note: 
 The output of the export will be identical to that of Record list in the main window, so 

please adjust the Record list in the main window to your satisfaction before exporting 
the records. 

 The default export path will be the application’s install path\export folder.  If you use 
the default installation path, then  it’s “C:\Program files\Hilary 
Technology\SecretKeeper 2\Export. 

 
1. From the main menu, go to File>Export. 
2. Select the desired categories, and click OK to export. 
3. Select the desired location to place the export file. 
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4. Upon successful export, the export file will be automatically opened for viewing. 
5. Take note of the location where you store the export file, and remember to delete the 

file for your protection once you finish using the file. 
 
 
Applying Filter/Search  
 

This option allows you to perform filter/search on records. Turning this option on will 
show the Filter Bar (a blank row positioned as the first record in the Record list), where 
you can enter the filter/search criteria in the desired columns. 

 
 
 

Clear Filterbar
Show/Hide Filterbar

 
 
 

  
Filter Bar shown as a blank row in the 1st record. 
 
1. To apply filter or perform search, go to View>Show Filter Bar, Or click  the Filter 

icon in the toolbar. 
2. Enter filter criteria in the desired column(s) on the top blank row. 
3. The filter results will show simultaneously as you enter the criteria. 
4. To clear the filter criteria, click the Clear Filterbar icon on the tool bar. 
 

 
 
Locking the Program 
 

You can lock the program before leaving your computer unattended. Once locked, the 
program is minimized, and to use it again, you will have to enter the correct password. 
 
1. To lock the program, go to main menu Tools>Lock Program, OR click the Lock icon 

in the toolbar. 
 
 

Lock Program
 
 
2. To unlock the program, enter the correct password in the Login screen. 
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Setting Viewing Options 
 

There are a few viewing options you can set within Secret Keeper. 
 
Show Masked Fields 
This option allows you to show the real values of the masked fields. When you don’t 
choose this option, values of the masked fields will show up as ***** in the main screen. 
 
1. To show or not show masked fields in the Record list, go to View> Show Masked 

Fields on the main menu.  
 

Show Filter Bar 
This option allows you to perform filter/search on records. Please refer to the section 
Applying Filter/Search for details. Click here. 
 

 
Show Multi-line in Cells 
This option allows you to view the records with multiple lines of text wrapped. 
 

 
Multi-line in action. 
 
1. From the main menu, go to View>Show Multi-line in Cells.  
2. By default, you will 2 lines of text with this option enabled. You can drag the a row to 

increase the row height and view more lines of text at once. 
 

Always On Top 
This option lets you set whether Secret Keeper should always stay on top when you have 
multiple programs running on your system. 
 
1. Go to View>Always On Top on the main menu.  
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Setting Application Options 
 

There are a number of handy application options you can set to enhance the security the 
program provides and the behaviours of the program. 
 

 
The Options screen. 
 
Clear Clipboard Options 
 You can choose to have the program automatically clear the clipboard at a fixed 

interval (between 1 to 60 min). And, 
 You can choose to always clear the Secret Keeper clipboard upon program exit. 

 
Note: 
It’s recommended you check off these options for optimal protection. 
 
Font Size Options 
 You may use font size between 7 to 17.  
 The font size change is applied only to Category & Record lists on the main window, 

and Category & Record management screens. 
 
Lock Program Options 
 You can choose to have the program automatically locked after certain idle time. 

(between 1 to 60 min). And, 
 You can choose to have the program automatically locked when the computer enters 

Screen Saver/Machine Lock modes.  And, 
 You can also have the program locked every time it’s minized. 

 
Note: 
It’s recommended you check off these options for optimal protection. 
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Administering the Database 
 

Secret Keeper utilizes a database to store all of its information. You can backup and restore 
all the information you have saved so that you will never lose any important information. 
Also, you can keep the application in good working order by compacting it from time to 
time.  

 
Backup 
1. On the main menu, go to Tools>Backup. 
2. Choose a location where you want to store the backup copy of the Secret Keeper 

database.  Or you can simply use the default location. 
3. The default location is the path to which you installed Secret Keeper. 
 
Restore 
1. To restore a previously backed up version of the database, go to Tools>Restore on the 

main menu.  
2. You will be prompted to select which database backup to restore from. 
3. Select the database and click OK. Click Cancel to exit without restoring.  
4. You will be redirected to the login screen when this process is completed. 
 
Compact 
1. To maintain the database and prevent data corruption of data, go to Tools>Compact on 

the main menu. 
2. Click OK to start. Click Cancel to exit without compacting the database.  
 
Note:  
It’s recommended that you compact the database once a month to keep the database in 
optimal conditions. 

 
 
Ordering SK2 Online 
 

To order Secret Keeper, please go to www.hilarytech.com 
 
 
Entering the Registration Key 

 
The trial version of SK2 has a limited usage of 50 times and after which you will have to 
purchase a license to continue using the program. Once you have obtained a license for 
your copy of Secret Keeper, you can enter the registration key to remove the trial 
restriction. 
 
1. From the main menu, go to Help>About.  
2. On the About screen, click the register button.  
3. Enter the registration name and registration key.  
4. Click OK when done.  
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Contacting Us 
 
General questions or feedback:   
info@hilarytech.com 
  
Sales questions or custom project inquires:  
sales@hilarytech.com 
  
Technical support:   
support@hilarytech.com 
  
Please include the following information when requesting technical support: 

1. Program title & version, 
2. Windows version, i.e Windows XP with SP3. 
3. Detailed description of your problem, i.e. what exactly we should do to get the 

same error message or problem. 
 

 
 
 
Copyright 2001-2009 Hilary Technology Inc. 
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